[FIX] USB automount not working – Ask Ubuntu

Question

I’m having an issue with usb automount on Ubuntu 21.10, kernel version: Linux Home 5.13.0-30-generic #33-Ubuntu

When I insert any usb device, it doesn’t get automounted, despite org.gnome.desktop.media-handling configuration:

$ gsettings get org.gnome.desktop.media-handling automount
true
$ gsettings get org.gnome.desktop.media-handling automount-open
true

Here is dmesg log after connecting my smartphone via usb:

[13265.122249] usb 3-6: new high-speed USB device number 7 using xhci_hcd
[13265.250291] usb 3-6: device descriptor read/64, error -32
[13265.506983] usb 3-6: New USB device found, idVendor=2717, idProduct=ff40, bcdDevice= 4.04
[13265.506991] usb 3-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[13265.506994] usb 3-6: Product: Redmi 9
[13265.506996] usb 3-6: Manufacturer: Xiaomi
[13265.506998] usb 3-6: SerialNumber: c**********
[13272.500089] usb 3-6: USB disconnect, device number 7
[13272.946154] usb 3-6: new high-speed USB device number 8 using xhci_hcd
[13273.094848] usb 3-6: New USB device found, idVendor=2717, idProduct=ff40, bcdDevice= 4.04
[13273.094862] usb 3-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[13273.094867] usb 3-6: Product: Redmi 9
[13273.094872] usb 3-6: Manufacturer: Xiaomi
[13273.094875] usb 3-6: SerialNumber: c**********

I couldn’t find any info about the line with “read/64, error -32”.
Any idea as to what might be wrong?

Click Here to see answer

0
payam 7 months 2022-03-05T15:34:46+00:00 0 Answers 8 views

Leave an answer

By answering, you agree to the Terms of Service and Privacy Policy.